support@vu.city    0808 168 3931 - Monday to Friday, 9am - 5:30pm GMT
VU.CITY Website    Log in
Search / ask a question...  

Release Notes

VU.CITY Desktop (click to expand):
VU.CITY 4.2.4 (2022) new

Key Features:

- New Screen Recorder tool for recording videos.

Enhancements:

- The A--X Point tool can now calculate the area between three or more points;
- UI improvements to the Create tool to simplify saving and loading models;
- You can now snap corners using the Create tool by holding shift as you click-and-drag;
- Distances between points will now be displayed when plotting the base of a model using the Create tool, and when editing the position of existing points;
- You can now drag-to-reposition models built using the Create tool just like you can with models imported from other software packages;
- The Create tool now has a Select All option;
- A Clear button has been added to the Camera Tool's view search field;
- Wider buttons in the Data menu to better display newer, more complex data sets;
- Selected buildings (red outline) will now appear in 360 degree panorama images;
- The name of a view in the Camera Tool will now appear in the metadata of exported 360 degree panorama images;
- Legends in the Data menu now dynamically resize based on the content;
- Minor UI text updates to make options / menus clearer.

Key Bug Fixes:

- Addressed an issue that caused shadows to appear in exported screenshots while shadows were turned off;
- Addressed an issue that could prevent previews from refreshing when changing camera settings in the Camera Tool;
- Addressed an issue that prevented the Camera Tool from working as expected while using the Create tool;
- Addressed an issue that could prevent users from cancelling out of creating a new Tag;
- Addressed an issue that caused a project's save time to appear as UTC instead of the user's actual timezone;
- Addressed an issue that could cause shadows that have been switched off to unexpectedly switch back on;
- Addressed an issue that could cause context geometry to not load when exporting views to image files;
- Addressed an unexpected error that could occur when taking screenshots after resetting a city model;
- Addressed an issue that caused a licence expiry message to appear on the city selector screen on the day of renewal;
- Addressed an issue that could cause hidden buildings from the Timeline to reappear when moving the orbit camera;
- Addressed an issue that could cause VU.CITY to become unresponsive when generating a 360 degree panorama image;
- Addressed an issue that caused overlayed photographs in protected views to disappear when toggling viewing corridors;
- Addressed an issue that caused the edit menu in the Create tool to remain open when no models were being edited;
- Addressed an issue that prevented context geometry loading correctly when batch-exporting images.

VU.CITY 4.0.2 (2022)

Key Features:

- Panoramic 360 Screenshots now available in the Camera Tool.

Enhancements:

- The Camera Tool edit panel can now be hidden while editing a view to maximise screenspace;
- JPEG is now used instead of PNG for exported images, improving upload/download speed and reducing disk space usage;
- UX improvements for the Create tool.

Key Bug Fixes:

- Addressed an issue that could prevent views from being exported when model freezing is off;
- Addressed an issue that caused the main toolbar to obscure options in the Camera Tool edit menu;
- Addressed an issue that allowed the height of a massing model to be editable using the Create tool when the massing is deselected;
- Addressed an issue that prevented exported IFC models from being re-imported;
- Addressed an issue that caused imported buildings to be deleted in error when deleting massing models using the Create tool.

VU.CITY 3.492.1 (2022)

Enhancements:

- Sunlight Tool now allows manual entry of time;
- Shortcut added to Sunlight Tool that takes you to today's date;
- Camera Tool sidebar can now be minimised while editing a view to maximise screenspace;
- Camera Tool sidebar now indicates the camera type (walk / building / orbit) you are editing;
- Exported CSV files from the Camera Tool will now show the lens length instead of the FOV;
- Various improvements made to the Save / Save As workflow;
- Various improvements to the object selector used by the Object Highlighter and Object Remover tools:
- The minimum and maximum camera lens size in camera studies has been expanded for greater customisation;
- Views added to the Camera Tool without a target selected will now default to the global rendering range;
- Protected Views will no longer show an on/off toggle when there is nothing to toggle off and on.

Key Bug Fixes:

- Addressed an issue that caused the camera to lock to the centre of the city in some situations;
- Addressed an issue that prevented context geometry from loading when resetting the city model in some situations;
- Addressed an issue that caused low-quality shadows in exported screenshots;
- Corrected the height of the river in the London city model;
- Addressed an issue that could affect camera study settings when switching between studies;
- Addressed an issue that prevented the full 16km range from loading when adjusting the Model Range;
- Addressed an issue that prevented editing a camera's pitch in some situations;
- Addressed an issue that prevented the Create Tool from successfully exporting FBX files;
- Addressed an issue that caused the camera study view options panel to remain on-screen after loading a new project;
- Addressed an issue that prevented some bulk actions in the Create Tool menu;
- Addressed an issue that could prevent VU.CITY from reconneting to VU.CITY Drive after a lost connection;
- Addressed an issue that could disable the range slider in the Camera Tool view editor;
- Addressed an issue that distorted Tags visible from within a camera study upon export;
- Addressed an issue that caused massings created with the Create tool to remain selected even after deleting them;
- Addressed an issue that prevented the rendering range to switch correctly between loading strategies when closing a walk camera;
- Addressed an issue that incorrectly triggered an error when loading geolocated models that have been saved into a project;
- Addressed an issue that caused empty camera studies to be appended to some projects;
- Addressed an issue that caused UK date formatting to switch to US in new camera studies;
- The Camera Tool will no longer encounter an error when loading a project with missing imported buildings.

VU.CITY 3.402.1 (2021)

Enhancements:

- Improved alignment of protected views;
- Improved UI messaging for long export times;
- The Select All toggle will now reset each time you open a new Camera Tool study;
- Improved UI wording in the Camera Tool study viewer;
- Whenever selecting Revit as the file origin, the Model Importer will now default to 'feet' as the scale unit.

Key Bug Fixes:

- Addressed an issue that cause the AOD of some wall-mounted cameras to default to 0;
- Addressed an issue that prevented some older projects from loading in the latest version of VU.CITY;
- Addressed an issue that prevented warning messages for some camera studies with missing thumbnails;
- Addressed an issue that affected the geolocation of some imported models when re-opening a project;
- Addressed an issue that prevented users from exiting some camera study views;
- Addressed an issue that caused the Object Highlighter to highlight previously highlighted models;
- Addressed an issue that caused some imported materials to swap or otherwise display in an unexpected way;
- Addressed an issue with some removed models reappearing unexpectedly;
- Addressed an issue with building highlighting not updating when the original model has been repositioned;
- Addressed an issue that caused some camera indicators (red arrows) to face the opposite direction;
- Addressed an issue that caused some hovering tool tips to appear behind the UI;
- Addressed an issue that prevented some models made using the Create tool from being deleted;
- Addressed an issue that prevented thumbnails from being generated for some Camera Tool views;
- Addressed an issue that caused the Camera Tool minimap to unexpectedly appear when closing the batch export menu;
- Addressed an issue with geometry tile-loading not working as expected after exiting a Camera Tool view;
- Addressed an issue that caused some geolocated models to trigger unexpected geolocation warnings;
- Addressed an issue that allowed the Camera Tool studies manager menu to be opened when using presentation mode.

VU.CITY 3.388.1 (2021)

Key Features:

- New Camera Tool including presentation mode;
- New Toolbar for quickly controlling global settings such as weather and trees.

Enhancements:

- Increased visibility of the scroll bar element on the licence selector screen.

Key Bug Fixes:

- Addressed an issue that prevented some older project files from opening.

VU.CITY 3.376.3 (2021)

Key Features:

- Updated logos throughout application to reflect VU.CITY rebrand.

Enhancements:

- Refactored project saving for improved performance;
- Refactored tree rendering for improved performance;
- Refactored graphical shaders for improved load times;
- Added error messaging when a project file fails to load.

Key Bug Fixes:

- Addressed an issue that prevented some data layers from rendering in exported screenshots;
- Addressed an issue that prevented image metadata from appearing at the bottom of exported screenshots;
- Addressed an issue where not all visible geometry in camera study views appeared in exported screenshots;
- Addressed an issue where some geometry visible in protected views did not appear in exported screenshots;
- Addressed an issue that caused UI elements to duplicate / overlap in exported screenshots;
- Addressed an issue that prevented some objects from being highlighted;
- Addressed an issue that prevented the object remover from working after deleting a highlighted massing model;
- Addressed an issue that prevented city geometry from loading after sudden camera movements;
- Addressed a keyboard input issue that could cause the application to become unresponsive;
- Addressed an issue that partially cropped historic building data;
- Addressed an issue that could cause parts of an offloaded project to save into the current project;
- Addressed an issue that caused the outline of a building to continue rendering after the model has been deleted;
- Addressed an issue that prevented ZTV studies from rendering correctly in merged projects.

VU.CITY 3.292.0 (2021)

Key Features:

- All new Zone of Theoretical Visibility (ZTV) tool has been added for easily calculating where your massing model can be seen from;
- Save and Save As functionality implemented to allow you to save over an existing project, or easily create a new version of it;
- Massing models from the Create tool can now be saved directly into your project;
- All new Tags tool:
    + Add geo-spatial tags to your projects including notes and images;
    + Use hashtags to easily find / filter tags from multiple sources;
    + Navigate to tagged locations with a single click.
- Tool tips will now appear when you hover your mouse over UI buttons that contain no text;

Enhancements:

- Improved upload performance when saving larger files or using slower internet connections;
- The Camera Studies tool will now remember which building you originally selected when you open an existing study;
- Screenshot rendering notifications will no longer appear in screenshots;
- Camera thumbnails no longer render data points;
- The enter key will now work on the login screen even when the login form isn't selected;
- Clearer notifications when dragging-and-dropping models into VU.CITY Cloud;
- Smooth transitions when switching between different cameras;
- Reflections on high-detail models are now supported;
- Opening the Create tool will no longer automatically return you to the orbit camera;
- Editing land registry boundary lines will no longer automatically return you to the orbit camera;
- Improved the quality of shadows cast while using the Camera Placer tool;
- Added the ability to adjust how far into the distance context models should appear within a Camera Study view;
- Added the ability to load elements from multiple projects (additive loading) and merge them into a single project;
- Improved encryption performance.

Key Bug Fixes:

- Addressed an issue that prevented some saved projects from appearing in the Load Project menu;
- Addressed an issue that prevented the names of imported models from appearing in the Import menu when loading some projects;
- Addressed an issue preventing some imported models from being highlighted;
- Addressed an issue that caused highlighted objects to not load after loading a project;
- Addressed an issue that caused the visibility toggle in the Create tool to display incorrectly;
- Addressed an issue that prevented custom colours in the Object Highlighter from being saved;
- Addressed an issue that caused an incorrect number of removed models to appear in the Object Remover menu after loading a project;
- Addressed an issue that sometimes caused removed buildings to reappear unexpectedly when using the Camera Studies tool;
- Addressed an issue that prevented announcements and promotional material from appearing on the login screen;
- The list and edit panels in the Create tool now consistently display the name of your model;
- The gizmos for moving and rotating imported models no longer overlap each other;
- Resetting the city will now also reset any highlighted models;
- Addressed an issue causing some imported models to be selected in pieces and not as a whole;
- Addressed an issue preventing some removed models from returning after resetting the city;
- Addressed an issue causing some Create models to disappear when navigating away from your site;
- Addressed an issue that could cause a Camera Placer camera's bearing to unexpectedly change;
- Addressed an issue that could cause a Camera Study camera's bearing and lens size to unexpectedly reset;
- Addressed an issue that prevented context geometry tiles from offloading when out of range;
- Addressed an issue that prevented some highlighted buildings from being recoloured;
- Addressed an issue that could cause an unexpected licence expiry notice after renewing an expired licence;
- Addressed an issue that prevented more than 16 models being imported into the same session;
- Addressed an issue in the Colouring London data layer that could cause toggle buttons to behave unexpectedly;
- Addressed multiple issues that prevented the editing of Land Registry boundary lines;
- Addressed an issue that prevented Camera Study submenus from closing as expected;
- Addressed an issue that prevented highlighting certain buildings when using the Camera Study tool;
- Addressed multiple issues that prevented surrounding context geometry from loading and offloading as expected;
- Addressed an issue that caused red camera markers to appear in some batched screenshots;
- Addressed an issue that caused sections of geometry to appear sliced off in some screenshots;
- Addressed an issue that caused long tag descriptions to not display;
- Addressed an issue that caused the Colouring London data layer to stop working after closing and reopening it;
- Addressed an issue that prevented the selection of massing models made using the Create tool;
- Addressed an issue that sometimes caused the ZTV tool to base its calculations on the incorrect building;
- Addressed an issue that prevented use of the Camera Placer while data layers are turned on;
- Addressed an issue that caused VU.CITY Cloud to become unresponsive when opening certain camera studies;
- Addressed an issue that caused camera study focal lengths to save as 36.93mm regardless of user input;
- Addressed an issue that caused surrounding context models to not load as expected when opening certain camera study views;
- Addressed an issue that caused city geometry tiles to not load when using micro-licences;
- Addressed an issue that caused highlighting applied to massings built using the Create tool not to save in your project; - Addressed an issue that caused unexpected UI elements to appear in screenshots.

VU.CITY 3.90.0 (2020)

Key Features:

- A new colour (dark gray) has been added to the timeline so you can now visualise when construction is complete;

- The model importer introduces a more natural workflow where you choose your 3d model first, then enter your import settings afterwards;
- You can now distinguish if a model includes import settings or not, as they will appear with a green icon in VU.CITY Drive if import settings are included;
- Drag-and-drop functionality added to the model importer. Simply drag any models you wish to import onto your VU.CITY window, and they will appear in the 'Ready To Import' list in the model importer menu ready for you to add the appropriate import settings;
- Imported models can now be rotated around their origin rather than around the centre of their mass;
- There is no longer any software limit to the number of models you can import;

- Improvements to Camera Studies (FKA View Cameras) including a clearer workflow with UI prompting;
- You can create aerial views in Camera Studies by increasing the AOD of any camera;
- Screenshots can now be saved directly to VU.CITY Drive (this includes batched screenshots from Camera Studies);
- You can now choose whether to include the location map in batched screenshots from Camera Studies;
- Toggles for moving/rotating models will no longer appear in screenshots;

- You can now save/load/export extruded models from the Create tool to VU.CITY Drive;

- New on-screen notifications ("toasts") with alerts that include:
    + Changes to your network connection status;
    + Progress of uploads to/downloads from VU.CITY Drive;
    + Progress of model imports;

- New network status indicator on the bottom right letting you know if you're online and connected to VU.CITY Drive;

- Higher quality shadows when at close range;

- Sub-menus in the Data menu allowing easier navigation as more and more data layers are added;
- New Land Registry Query tool added to the Data menu allows users to visualise the boundary lines of buildings they select, and see data associated with it;
- New Land Registry Query tool added to the Data menu allows users to visualise the boundary lines of buildings they select, and see data associated with it;
- Higher resolution and accuracy for all data sets;

- The online dashboard now allows you to filter file types and select multiple files at once in VU.CITY Drive;
- You now have the option to share files indefinitely via VU.CITY Drive;

- New and improved login portal and city licence selector screen;
- Users will now be prompted to save changes on exit, and when resetting/leaving a city;

Key Bug Fixes:

- Addressed an issue causing some saved screenshots to not match what you see on screen;
- Addressed an issue causing the main camera to become stuck when loading certain project;
- Addressed an issue causing some models to appear in the incorrect scale/location when loading a project;
- Addressed an issue causing models made up of multiple objects to break into pieces upon import;
- Addressed an issue preventing certain models from saving to your Project if downloaded from VU.CITY Drive;
- When using the Camera Placer, the UI now correctly reflects that tile loading has been turned off.

VU.CITY 3.1.0 (2019)

General:

- The UTM coordinate system has now been integrated, allowing us to add any city in the world to the platform;
- Keyboard controls can now be used uniformly when moving the Orbit Camera, Walk Camera, and any cameras placed on buildings;
- GEA is now calculated for each building (and the entire site) when extruding buildings with the Create tool;
- The position/rotation gizmos (red/green/blue handles for adjusting your model) will no longer appear in screenshots;
- Improved touch controls for touchscreen users (desktop only);
- Improved analytics and crash reporting.

Data:

- 20 New data layers in Belfast;
- ZTV of St Paul's data layer for all London licence holders.

Camera Studies:

- You can now manually generate aerial views by adjusting the AOD/pitch/bearing of cameras inside your View Camera study;
- Saving batch screen grabs from Views Camera studies will now no longer override one another;
- Fixed an issue that sometimes caused the AOD value in the camera placer menu to snap to an unexpected value;
- Fixed an issue causing some view camera previews (thumbnails) to not match the actual view.

Model Importer:

- Standard transparent materials are now supported, allowing you to recreate the look of glass on your 3d models;
- Fixed an issues that caused some models to import at 0,0,0 with x10 scale.

Bug fixes:

- Hyperlinks in the data panel now display correctly;
- Fixed an issue causing camera settings displayed at the bottom of screenshots to not match the actual camera settings;
- Fixed an issue whereby changing the display resolution could affect your ability to click on buildings;
- Fixed an issue with with transparency not always being applied correctly to highlighted buildings;
- Fixed an issue whereby the mini-map did not always render terrain.

VU.CITY Cloud (click to expand):
VU.CITY 4.2.4 (2022) new

Key Features:

- New Screen Recorder tool for recording videos.

Enhancements:

- The A--X Point tool can now calculate the area between three or more points;
- UI improvements to the Create tool to simplify saving and loading models;
- You can now snap corners using the Create tool by holding shift as you click-and-drag;
- Distances between points will now be displayed when plotting the base of a model using the Create tool, and when editing the position of existing points;
- You can now drag-to-reposition models built using the Create tool just like you can with models imported from other software packages;
- The Create tool now has a Select All option;
- A Clear button has been added to the Camera Tool's view search field;
- Wider buttons in the Data menu to better display newer, more complex data sets;
- Selected buildings (red outline) will now appear in 360 degree panorama images;
- The name of a view in the Camera Tool will now appear in the metadata of exported 360 degree panorama images;
- Legends in the Data menu now dynamically resize based on the content;
- Minor UI text updates to make options / menus clearer.

Key Bug Fixes:

- Addressed an issue that caused shadows to appear in exported screenshots while shadows were turned off;
- Addressed an issue that could prevent previews from refreshing when changing camera settings in the Camera Tool;
- Addressed an issue that prevented the Camera Tool from working as expected while using the Create tool;
- Addressed an issue that could prevent users from cancelling out of creating a new Tag;
- Addressed an issue that caused a project's save time to appear as UTC instead of the user's actual timezone;
- Addressed an issue that could cause shadows that have been switched off to unexpectedly switch back on;
- Addressed an issue that could cause context geometry to not load when exporting views to image files;
- Addressed an unexpected error that could occur when taking screenshots after resetting a city model;
- Addressed an issue that caused a licence expiry message to appear on the city selector screen on the day of renewal;
- Addressed an issue that could cause hidden buildings from the Timeline to reappear when moving the orbit camera;
- Addressed an issue that could cause VU.CITY to become unresponsive when generating a 360 degree panorama image;
- Addressed an issue that caused overlayed photographs in protected views to disappear when toggling viewing corridors;
- Addressed an issue that caused the edit menu in the Create tool to remain open when no models were being edited;
- Addressed an issue that prevented context geometry loading correctly when batch-exporting images.

VU.CITY 4.0.2 (2022)

Key Features:

- Panoramic 360 Screenshots now available in the Camera Tool.

Enhancements:

- The Camera Tool edit panel can now be hidden while editing a view to maximise screenspace;
- JPEG is now used instead of PNG for exported images, improving upload/download speed and reducing disk space usage;
- UX improvements for the Create tool.

Key Bug Fixes:

- Addressed an issue that could prevent views from being exported when model freezing is off;
- Addressed an issue that caused the main toolbar to obscure options in the Camera Tool edit menu;
- Addressed an issue that allowed the height of a massing model to be editable using the Create tool when the massing is deselected;
- Addressed an issue that prevented exported IFC models from being re-imported;
- Addressed an issue that caused imported buildings to be deleted in error when deleting massing models using the Create tool.

VU.CITY 3.492.1 (2022)

Enhancements:

- Sunlight Tool now allows manual entry of time;
- Shortcut added to Sunlight Tool that takes you to today's date;
- Camera Tool sidebar can now be minimised while editing a view to maximise screenspace;
- Camera Tool sidebar now indicates the camera type (walk / building / orbit) you are editing;
- Exported CSV files from the Camera Tool will now show the lens length instead of the FOV;
- Various improvements made to the Save / Save As workflow;
- Various improvements to the object selector used by the Object Highlighter and Object Remover tools:
- The minimum and maximum camera lens size in camera studies has been expanded for greater customisation;
- Views added to the Camera Tool without a target selected will now default to the global rendering range;
- Protected Views will no longer show an on/off toggle when there is nothing to toggle off and on.

Key Bug Fixes:

- Addressed an issue that caused the camera to lock to the centre of the city in some situations;
- Addressed an issue that prevented context geometry from loading when resetting the city model in some situations;
- Addressed an issue that caused low-quality shadows in exported screenshots;
- Corrected the height of the river in the London city model;
- Addressed an issue that could affect camera study settings when switching between studies;
- Addressed an issue that prevented the full 16km range from loading when adjusting the Model Range;
- Addressed an issue that prevented editing a camera's pitch in some situations;
- Addressed an issue that prevented the Create Tool from successfully exporting FBX files;
- Addressed an issue that caused the camera study view options panel to remain on-screen after loading a new project;
- Addressed an issue that prevented some bulk actions in the Create Tool menu;
- Addressed an issue that could prevent VU.CITY from reconneting to VU.CITY Drive after a lost connection;
- Addressed an issue that could disable the range slider in the Camera Tool view editor;
- Addressed an issue that distorted Tags visible from within a camera study upon export;
- Addressed an issue that caused massings created with the Create tool to remain selected even after deleting them;
- Addressed an issue that prevented the rendering range to switch correctly between loading strategies when closing a walk camera;
- Addressed an issue that incorrectly triggered an error when loading geolocated models that have been saved into a project;
- Addressed an issue that caused empty camera studies to be appended to some projects;
- Addressed an issue that caused UK date formatting to switch to US in new camera studies;
- The Camera Tool will no longer encounter an error when loading a project with missing imported buildings.

VU.CITY 3.402.1 (2021)

Enhancements:

- Improved alignment of protected views;
- Improved UI messaging for long export times;
- The Select All toggle will now reset each time you open a new Camera Tool study;
- Improved UI wording in the Camera Tool study viewer;
- Whenever selecting Revit as the file origin, the Model Importer will now default to 'feet' as the scale unit.

Key Bug Fixes:

- Addressed an issue that cause the AOD of some wall-mounted cameras to default to 0;
- Addressed an issue that prevented some older projects from loading in the latest version of VU.CITY;
- Addressed an issue that prevented warning messages for some camera studies with missing thumbnails;
- Addressed an issue that affected the geolocation of some imported models when re-opening a project;
- Addressed an issue that prevented users from exiting some camera study views;
- Addressed an issue that caused the Object Highlighter to highlight previously highlighted models;
- Addressed an issue that caused some imported materials to swap or otherwise display in an unexpected way;
- Addressed an issue with some removed models reappearing unexpectedly;
- Addressed an issue with building highlighting not updating when the original model has been repositioned;
- Addressed an issue that caused some camera indicators (red arrows) to face the opposite direction;
- Addressed an issue that caused some hovering tool tips to appear behind the UI;
- Addressed an issue that prevented some models made using the Create tool from being deleted;
- Addressed an issue that prevented thumbnails from being generated for some Camera Tool views;
- Addressed an issue that caused the Camera Tool minimap to unexpectedly appear when closing the batch export menu;
- Addressed an issue with geometry tile-loading not working as expected after exiting a Camera Tool view;
- Addressed an issue that caused some geolocated models to trigger unexpected geolocation warnings;
- Addressed an issue that allowed the Camera Tool studies manager menu to be opened when using presentation mode.

VU.CITY 3.388.1 (2021)

Key Features:

- New Camera Tool including presentation mode;
- New Toolbar for quickly controlling global settings such as weather and trees.

Key Bug Fixes:

- Addressed an issue that prevented some older project files from opening.

VU.CITY 3.384.4 (2021)

Enhancements:

- Increased visibility of the scroll bar element on the licence selector screen;
- Opening a camera study will no longer auto-load the first view.

Key Bug Fixes:

- Addressed an issue that could cause the Camera Studies tool to become unresponsive when opening a Camera Study;
- Addressed an issue that could cause trees to flicker;
- Addressed an issue that could cause VU.CITY to become unresponsive when attempting to save from the exit/reset screen.

VU.CITY 3.376.3 (2021)

Key Features:

- Updated logos throughout application to reflect VU.CITY rebrand.

Enhancements:

- Refactored project saving for improved performance;
- Refactored tree rendering for improved performance;
- Refactored graphical shaders for improved load times;
- Added error messaging when a project file fails to load.

Key Bug Fixes:

- Addressed an issue that incorrectly forced some display aspect ratios into 16:9;
- Addressed an issue that prevented some data layers from rendering in exported screenshots;
- Addressed an issue that prevented image metadata from appearing at the bottom of exported screenshots;
- Addressed an issue where not all visible geometry in camera study views appeared in exported screenshots;
- Addressed an issue where some geometry visible in protected views did not appear in exported screenshots;
- Addressed an issue that caused UI elements to duplicate / overlap in exported screenshots;
- Addressed an issue that prevented some objects from being highlighted;
- Addressed an issue that prevented the object remover from working after deleting a highlighted massing model;
- Addressed an issue that prevented city geometry from loading after sudden camera movements;
- Addressed a keyboard input issue that could cause the application to become unresponsive;
- Addressed an issue that partially cropped historic building data;
- Addressed an issue that could cause parts of an offloaded project to save into the current project;
- Addressed an issue that caused the outline of a building to continue rendering after the model has been deleted;
- Addressed an issue that prevented ZTV studies from rendering correctly in merged projects.

VU.CITY 3.292.0 (2021)

Key Features:

- Tool tips will now appear when you hover your mouse over UI buttons that contain no text;

Key Bug Fixes:

- Addressed an issue that caused highlighting applied to massings built using the Create tool not to save in your project;
- Addressed an issue that caused unexpected UI elements to appear in screenshots.

VU.CITY 3.276.0 (2021)

Key Bug Fixes:

- Addressed an issue that caused city geometry tiles to not load when using micro-licences.

VU.CITY 3.274.2 (2021)

Key Bug Fixes:

- Addressed an issue that caused VU.CITY Cloud to become unresponsive when opening certain camera studies;
- Addressed an issue that caused camera study focal lengths to save as 36.93mm regardless of user input;
- Addressed an issue that caused surrounding context models to not load as expected when opening certain camera study views.

VU.CITY 3.257.5 (2021)

Enhancements:

- Improved the quality of shadows cast while using the Camera Placer tool;
- Inverted the colour scheme of the ZTV tool so that warm colours represent high visibility, and cool colours represent low visibility;
- Added the ability to adjust how far into the distance context models should appear within a Camera Study view;
- Added the ability to load elements from multiple projects (additive loading) and merge them into a single project;
- Improved encryption performance.

Key Bug Fixes:

- Addressed an issue that prevented more than 16 models being imported into the same session;
- Addressed an issue in the Colouring London data layer that could cause toggle buttons to behave unexpectedly;
- Addressed multiple issues that prevented the editing of Land Registry boundary lines;
- Addressed an issue that prevented Camera Study submenus from closing as expected;
- Addressed an issue that prevented highlighting certain buildings when using the Camera Study tool;
- Addressed multiple issues that prevented surrounding context geometry from loading and offloading as expected;
- Addressed an issue that caused red camera markers to appear in some batched screenshots;
- Addressed an issue that caused sections of geometry to appear sliced off in some screenshots;
- Addressed an issue that caused long tag descriptions to not display;
- Addressed an issue that caused the Colouring London data layer to stop working after closing and reopening it;
- Addressed an issue that prevented the selection of massing models made using the Create tool;
- Addressed an issue that sometimes caused the ZTV tool to base its calculations on the incorrect building;
- Addressed an issue that prevented use of the Camera Placer while data layers are turned on.

VU.CITY 3.182.0 (2020)

Enhancements:

- Visual enhancements to the Tags tool;
- Opening the Create tool will no longer automatically return you to the orbit camera;
- Editing land registry boundary lines will no longer automatically return you to the orbit camera.

Key Bug Fixes:

- Addressed an issue that could cause a Camera Placer camera's bearing to unexpectedly change;
- Addressed an issue that could cause a Camera Study camera's bearing and lens size to unexpectedly reset;
- Addressed an issue that prevented context geometry tiles from offloading when out of range;
- Addressed an issue that prevented some highlighted buildings from being recoloured;
- Addressed an issue that could cause an unexpected licence expiry notice after renewing an expired licence.

VU.CITY 3.156.0 (2020)

Key Features:

- All new Tags tool:
    + Add geo-spatial tags to your projects including notes and images;
    + Use hashtags to easily find / filter tags from multiple sources;
    + Navigate to tagged locations with a single click.

Enhancements:

- Smooth transitions when switching between different cameras;
- Reflections on high-detail models are now supported.

Key Bug Fixes:

- The list and edit panels in the Create tool now consistently display the name of your model;
- The gizmos for moving and rotating imported models no longer overlap each other;
- Resetting the city will now also reset any highlighted models;
- Addressed an issue causing some imported models to be selected in pieces and not as a whole;
- Addressed an issue preventing some removed models from returning after resetting the city;
- Addressed an issue causing some Create models to disappear when navigating away from your site.

VU.CITY 3.130.0 (2020)

Key Features:

- All new Zone of Theoretical Visibility (ZTV) tool has been added for easily calculating where your massing model can be seen from;
- Save and Save As functionality implemented to allow you to save over an existing project, or easily create a new version of it;
- Massing models from the Create tool can now be saved directly into your project.

Enhancements:

- Improved upload performance when saving larger files or using slower internet connections;
- The Camera Studies tool will now remember which building you originally selected when you open an existing study;
- Screenshot rendering notifications will no longer appear in screenshots;
- Camera thumbnails no longer render data points;
- The enter key will now work on the login screen even when the login form isn't selected;
- Clearer notifications when dragging-and-dropping models into VU.CITY Cloud.

Key Bug Fixes:

- Addressed an issue that prevented some saved projects from appearing in the Load Project menu;
- Addressed an issue that prevented the names of imported models from appearing in the Import menu when loading some projects;
- Addressed an issue preventing some imported models from being highlighted;
- Addressed an issue that caused highlighted objects to not load after loading a project;
- Addressed an issue that caused the visibility toggle in the Create tool to display incorrectly;
- Addressed an issue that prevented custom colours in the Object Highlighter from being saved;
- Addressed an issue that caused an incorrect number of removed models to appear in the Object Remover menu after loading a project;
- Addressed an issue that sometimes caused removed buildings to reappear unexpectedly when using the Camera Studies tool;
- Addressed an issue that prevented announcements and promotional material from appearing on the login screen.

Technical information for your IT team



Privacy Policy  |  Cookie Policy
© 2022 All rights reserved VU.CITY Limited